'82 Kawasaki Spectre 750 no tail lights or hazard

Reply

  #1  
Old 03-11-09, 08:38 PM
Member
Thread Starter
Join Date: Sep 2006
Location: morristown
Posts: 40
Question '82 Kawasaki Spectre 750 no tail lights or hazard

I have a 1982 Kawasaki Spectre 750. I recently noticed the tail lights and hazard lights dont work. I replaced the bulbs didnt help. I looked at the socket but im not quite sure what to look for. Any help with this problem will be appreciated.
 
Sponsored Links
  #2  
Old 03-12-09, 04:50 AM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,143
If you think the problem is a bad contact at the light look for corrosion where the wires attach to the fixture and where the bulb makes contact with the socket. You can clean the contacts with fine sandpaper or a ScotchBrite cleaning pad (an abrasive pad for buffing metal, available from an auto supply or auto body shop) then cover the area with dielectric grease (non-conductive grease for electrical parts, you can find it at automotive stores) to prevent corrosion in the future.

Don't forget to check your fuses. Also, if you have a volt meter or current tester check to see that you are getting power to your tailight.
 
  #3  
Old 03-12-09, 09:01 PM
Member
Thread Starter
Join Date: Sep 2006
Location: morristown
Posts: 40
Question forgot to mention

I forgot to mention the blinker lights work so it must be getting some kind of connection.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'