Help with Meit Cyclops Scooter

Reply

  #1  
Old 09-13-09, 05:49 PM
Member
Thread Starter
Join Date: Sep 2009
Location: US
Posts: 2
Help with Meit Cyclops Scooter

Hey all i have a 2008 Meit Cyclops 49cc scooter and the other day i was driving it and it died on me. After trying to start it for a few tries it did start. I drove it home and parked it the next morning i relized that it was runny funny. cutting out and doing little back fires. and then it died and would try to start then would die. and if i bounced on the seat it would start and die. cant figure out how to get it running or what wrong with it. its my only transportation please help me.
 
Sponsored Links
  #2  
Old 09-14-09, 07:36 AM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,563
I've never heard of & I can't find any info on these.. Do the people you bought it from have any suggestions?? If not, try a new spark plug in it... If this is one of the chinese imported scooters,, I've seen a lot of them with bad plugs... If you have a known good spark plug,, check for spark when it quits... Good Luck... Roger
 
  #3  
Old 09-14-09, 08:50 AM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 18,304
If the scooter will start & run when you bounce the seat I am wondering if there is some type of fuel problem.

Check to make sure that gas is getting all the way to the carburetor. There may be dirt clogging a fuel line.

Does the scooter have a float type carburetor? If so check to see if the float is stuck.
 
  #4  
Old 09-14-09, 09:38 AM
Member
Thread Starter
Join Date: Sep 2009
Location: US
Posts: 2
I took the fuel line off that runs into the carb and fuel came running out so its getting fuel.
 
  #5  
Old 09-14-09, 10:12 AM
hopkinsr2's Avatar
Member
Join Date: Feb 2005
Location: canada
Posts: 1,563
But is the fuel getting INTO the carb?? the needle valve may be blocked..Pull the bowl off & make sure you have a good flow INTO the carb... Have you checked for a strong spark when it quits (with a known good plug) Have you tried a new plug or contacted the place you bought it from?? Maybe they can help you out as this isn't a common machine & if they specilize or sell them I trust they have tech's that have been trained & parts support to back up their product... Roger
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes