1992 36 volt

Reply

  #1  
Old 04-19-11, 07:42 PM
S
Member
Thread Starter
Join Date: Apr 2011
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
1992 36 volt

Can someone please tell me how to test my controller to see if it is any good.
 
Sponsored Links
  #2  
Old 04-20-11, 04:24 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,964
Received 676 Votes on 625 Posts
What brand cart do you have? What makes you think you have a problem with the controller?
 
  #3  
Old 04-20-11, 07:38 AM
S
Member
Thread Starter
Join Date: Apr 2011
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
ezgo

sorry i have a 1992 ezgo 36 volt marathon.
all bats are only 2 years old and they have a full charge all wires are in good shape and tight. but you can onlt go about 200 yards @ 3 mph then it starts SLOWING DOWN as if 3 MPH is not slow enough LOL !! so i thought i would test the controller.
 
  #4  
Old 04-20-11, 07:56 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,964
Received 676 Votes on 625 Posts
Boy, that sounds like a battery problem. How do you know the batteries are charged. Is it just because the charger was hooked to it over night or are you taking a gravity reading of each battery cell or reading the voltage? I'm wondering if you have a bad cell or bad battery.

Do you have a volt meter? First I would attach the meter to each end of your battery wiring where you should see about 38 volts when not driving the cart. Drive the cart with the volt meter attached and see what you get. If you don't have over 36 volts or if the voltage takes a dive when driving I would then disconnect the cables from the batteries and check the voltage of each one independently. They should have pretty close to the same voltage but if one is lower than the others you need to look at that one more closely.

Have you checked each battery cell for water? Do you have a battery specific gravity tester to test the acid in each cell?
 
  #5  
Old 04-20-11, 09:53 AM
S
Member
Thread Starter
Join Date: Apr 2011
Location: usa
Posts: 4
Received 0 Votes on 0 Posts
i have load test each bat and did every test to the bats i can think of.i think it is the controller or the speed controller. would like to find a way to test each of them. note without load bats read 37.40 under load 37.03
 

Last edited by Southernstyle; 04-20-11 at 10:14 AM.
  #6  
Old 04-20-11, 01:16 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,964
Received 676 Votes on 625 Posts
I think your cart has a 1204 Curtis controller. I'm a bit short of time right now but here is a link to the manual for that controller. There is a trouble shooting section that might help.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question