2 Stroke engine sputters and backfires

Reply

  #1  
Old 09-14-12, 10:22 PM
Member
Thread Starter
Join Date: Sep 2012
Location: usa
Posts: 2
Lightbulb 2 Stroke engine sputters and backfires

I have a 5 year old scooter with a 40cc two stroke engine. It was running great until a couple days ago. I was warming it up for my son to ride and it was idling nicely in the driveway when it suddenly sputtered to a stop. I attempted to restart it but it sputters and backfires.

It has a Walbro WYK-119 carburetor on it. Any ideas???? Possibly an air leak in the carburetor? I would appreciate any input. Thanks
 
Sponsored Links
  #2  
Old 09-17-12, 05:22 AM
Member
Join Date: Jan 2012
Location: Canada
Posts: 2,541
If it's been running good until a few days ago, I would wonder if the plug is fouling or bad gas.

Could be the carb, but I would check the plug and if you are using old fuel, maybe drain and replace.
 
  #3  
Old 09-17-12, 03:30 PM
Member
Join Date: Aug 2012
Posts: 7
When I used to turn wrenches for a Honda/Yamaha dealership we would see a lot of clogged mufflers on two-stroke scooters, (just another idea).
 
  #4  
Old 09-17-12, 08:31 PM
Member
Thread Starter
Join Date: Sep 2012
Location: usa
Posts: 2
Thank you for the replies. The spark plug was the problem. The plug was on it last legs and not firing consistently. Problem solved! Thanks again
 
  #5  
Old 09-18-12, 05:55 AM
Member
Join Date: Jan 2012
Location: Canada
Posts: 2,541
Thank you for the replies. The spark plug was the problem. The plug was on it last legs and not firing consistently. Problem solved! Thanks again
Glad to hear it's back up and running.
There is a reason we always carried spare plugs with us while riding 2-strokes.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'