95 magna won't start


  #1  
Old 05-01-14, 04:18 PM
U
Member
Thread Starter
Join Date: May 2014
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
95 magna won't start

OK I have a 95 magna and it won't start I have put new tank and petcock on the bike because of rust issues with the old one. If I spray gas onto the carbs it tries to start but then shuts right off. I need help
 
  #2  
Old 05-01-14, 06:54 PM
G
Member
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,290
Upvotes: 0
Received 2 Upvotes on 2 Posts
Welcome to the forums.
If memory serves, I recall that the Magna's had an electric fuel pump.. First step would be to check and see if it is working. They did have a reputation for failing after a period of time.
Check and replace the fuel filter, if it has one. Next step would be to tear down and rebuild the carbs.

There are after market service manuals available. Definitely get and study one before you tackle the carbs.
 
  #3  
Old 05-25-14, 01:52 PM
A
Member
Join Date: May 2014
Posts: 9
Upvotes: 0
Received 0 Upvotes on 0 Posts
I don't have much experience working on Magnas but most of the time when a bike doesn't start its either fuel related or electrical.
If the carbs haven't been cleaned and gone through I would do that first.Also use an inline fuel filter from the tank down to the carbs.
Another thing after you rebuilts the carbs and thoroughly clean them sync them also.This can be quite complicated if you have 2 or more carbs.Alos try and find a motorcycle forum related to your bike.
Im dealing with a no start issue on my Yamaha xs but its because of vandalism,someone has taken electrical relays related to the ignition system.
Good luck.
 
 

Thread Tools
Search this Thread
 
Ask a Question