Yamaha G9 cart help Please!


  #1  
Old 06-05-16, 01:08 PM
S
Member
Thread Starter
Join Date: Jun 2016
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Yamaha G9 cart help Please!

Hi all have a yamaha g9 cart has ran great for years was driving today went through some wet wet grass on route back to the trailer the cart died has lots of gas hooked up battery charger battery appears good. I did notice when the key is on the carts totally dead I don't even get the reverse warning beep when it's in gear? Doesn't even try to turn over
Please help

Thanks in advance
 
  #2  
Old 06-05-16, 03:59 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,367
Received 2,323 Upvotes on 2,066 Posts
The battery is dead or you have a broken wire/connection if you don't even get the reverse beeper.
 
  #3  
Old 06-05-16, 04:15 PM
J
Member
Join Date: Jan 2011
Location: USA
Posts: 4,463
Received 129 Upvotes on 114 Posts
Guess where going to have to guess.
Is it a gas or electric cart?
Plenty of gas so where going to guess it's gas.
I'd be removing and cleaning every terminal to the starter, solinoid, battery and cleaning it off with a wire brush.
 
  #4  
Old 06-05-16, 05:18 PM
S
Member
Thread Starter
Join Date: Jun 2016
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hey joe it's gas hence me saying I checked the gas level thanks for the tips I'll check the connections I agree pretty weird it was running then just died out could anything have gotten wet? Or do you think it's definetly a broken wire or dead battery? If the solenoids bad in would still have a reverse warning right it just wouldn't start this things driving me nuts lol
 
  #5  
Old 06-06-16, 04:49 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,367
Received 2,323 Upvotes on 2,066 Posts
The reverse beeper is on a parallel circuit to the solenoid and will work even if the solenoid doesn't. The reverse beeper will usually work even when nothing else on the cart does. It's battery, fuse, ignition switch, reverse switch and beeper. If you're not getting the beeper and the solenoid doesn't engage and the starter doesn't engage then I'd first check the battery and it's connections.
 
 

Thread Tools
Search this Thread
 
Ask a Question