Running lean at WOT


  #1  
Old 05-08-18, 09:30 PM
H
Member
Thread Starter
Join Date: Sep 2010
Location: united states
Posts: 375
Received 2 Upvotes on 2 Posts
Running lean at WOT

1999 bmw r1100rt idles fine but when you jump on the throttle it Boggs down and struggles. I made the executive decision that its running lean after 1/4 throttle and confirmed this by shoving a rag into the air intake with hopes of starving it from air as it is fuel and it worked. Bike runs at 85%. Not able to hit my top speed but other than that running much better. Is there anyone out there that know how the fiel/air mixture works on these bikes?
 
  #2  
Old 05-09-18, 05:27 AM
M
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,867
Received 37 Upvotes on 36 Posts
Try running some Sea Foam through it. When you put the rag in the intake you were essentially choking it. The result is a richer mixture which you apparently need.

The problem with choking is the restriction of full air flow. That would cut your top end by the amount of the restriction.

Sounds like a dirty carb.
 
  #3  
Old 05-09-18, 09:00 AM
H
Member
Thread Starter
Join Date: Sep 2010
Location: united states
Posts: 375
Received 2 Upvotes on 2 Posts
Its fuel injected with TBs. I put in new injectors over the winter and cleaned the TBs. I'm thinking its a bad throttle position sensor but couldn't get anyone to chime in on a bmw forum so I thought I try here.
 
  #4  
Old 05-10-18, 07:24 AM
M
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,867
Received 37 Upvotes on 36 Posts
I understand. It could be electronic, but it could also still be fuel flow restriction. Sea Foam could help and it's not expensive.

Does that bike have any type of OBD systems like a car to read trouble codes?
 
 

Thread Tools
Search this Thread
 
Ask a Question