1982 Yamaha G1

Reply

  #1  
Old 09-04-18, 01:11 PM
Member
Thread Starter
Join Date: Feb 2016
Location: usa
Posts: 28
Received 0 Votes on 0 Posts
1982 Yamaha G1

Really need some help. I recently purchased this golf cart and it only will run without air filter. When filter is attached, engine will load up, flood and die. Without filter attached, it runs like a new machine.
 
Sponsored Links
  #2  
Old 09-04-18, 01:30 PM
Member
Join Date: Jan 2013
Location: U.S.A.
Posts: 2,079
Received 65 Votes on 60 Posts
I would start with a carburetor teardown and cleaning, not just spraying something in the throat, and dumping and putting fresh fuel in the tank.
 
  #3  
Old 09-04-18, 02:02 PM
Member
Thread Starter
Join Date: Feb 2016
Location: usa
Posts: 28
Received 0 Votes on 0 Posts
Thanks Pedro. I have soaked carb in ultrasonic cleaner several times. It looks like previous owner has installed an aftermarket carb that looks relatively new. It started loading up after I installed new crank seals. I just got done removing exhaust and using air to make sure not obstructed and checked port for carbon build up. Piston really looks in good shape. I'm running out of ideas.
 
  #4  
Old 09-05-18, 01:01 PM
Member
Thread Starter
Join Date: Feb 2016
Location: usa
Posts: 28
Received 0 Votes on 0 Posts
Turns out it was the carb. I found a used OEM at local shop. Thanks for the help
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question