Need help with 80cc small engine

Reply

  #1  
Old 12-20-18, 11:00 PM
F
Member
Thread Starter
Join Date: Dec 2018
Posts: 3
Received 0 Votes on 0 Posts
Need help with 80cc small engine

Ive been working on a mini bike for quite some time now it was running good untill i gave it an oil change now when i pull the cord it spits gas and air back out the carb i took the carb off and clean it checked the float and its all good but it still spits out and wont start can someone help
 
  #2  
Old 12-21-18, 03:33 AM
A
Member
Join Date: Aug 2015
Location: USA
Posts: 637
Received 24 Votes on 23 Posts
would start with the basic checks like does it have spark?
does it have compression did you check it with a gauge?
is the exhaust restricted does it attempt to run with the exhaust off?
those 3 checks may help to figure out what is wrong would start there.
 
  #3  
Old 12-21-18, 05:44 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 24,703
Received 785 Votes on 722 Posts
Are you certain an oil change was the only thing you did when it quit running? I would double check the oil level. Also, did you lay the engine on it's side or upside down at any time?
 
  #4  
Old 12-21-18, 10:00 AM
F
Member
Thread Starter
Join Date: Dec 2018
Posts: 3
Received 0 Votes on 0 Posts
I checked spark and compression i did have to lay it on the side to undo the mounting bolts to drain the oil and it has a straight pipe exaust on it
 
  #5  
Old 12-21-18, 03:22 PM
A
Member
Join Date: Aug 2015
Location: USA
Posts: 637
Received 24 Votes on 23 Posts
how much compression did it have?
what model type of bike your actually working on may help with some replies.

besides spits gas and air out of carb do your hear it backfire or any attempt to start?
 
  #6  
Old 12-21-18, 03:40 PM
F
Member
Thread Starter
Join Date: Dec 2018
Posts: 3
Received 0 Votes on 0 Posts
Its a monster moto 80cc the compression ratio was 8.5:1 no back firing in the past and it trys to start when i spray starting fluid in it but doesnt fully start
 
  #7  
Old 12-21-18, 05:46 PM
A
Member
Join Date: Aug 2015
Location: USA
Posts: 637
Received 24 Votes on 23 Posts
suspect there is nothing major wrong with it from just changing the oil maybe it flooded or perhaps you got oil in the intake from having it on its side would try removing sparkplug clean and dry the spark plug and pour a cap full of oil down the plug hole and crank it over several times with the plug out to remove excess oil and gas from the cylinder before reinstalling the plug and trying to start it.

A compression gauge threads into the spark plug hole and when you crank it over reads a pressure reading usually in psi this is completely different from compression ratio witch is just volume of cylinder and head when piston is at bottom dead center and at top dead center so the 8.5 to 1 compression ratio the engine was designed with is of no help at all in diagnosing why it wont start.
 
  #8  
Old 02-13-19, 03:56 PM
N
Member
Join Date: Feb 2019
Posts: 3
Received 0 Votes on 0 Posts
80 cc

Clean out card. Oil in bowl or float stuck
 
  #9  
Old 02-13-19, 04:05 PM
Rough Rooster's Avatar
Member
Join Date: Feb 2014
Location: USA
Posts: 430
Received 6 Votes on 6 Posts
If it is a 2 stroke, put the reed valve on properly.

RR :
 
  #10  
Old 02-14-19, 06:35 AM
M
Member
Join Date: Dec 2017
Location: usa
Posts: 38
Received 2 Votes on 2 Posts
By laying it on its side, oil got into the cylinder. Pull the plug and clean it. While the plug is out crank it over to blow out the oil in the combustion area. You may have also messed up the float in the carb, but my money is oil in the cylinder.
 
 

Thread Tools
Search this Thread
 
Ask a Question