Engine running rough

Reply

  #1  
Old 09-06-02, 01:59 PM
PCS
Visiting Guest
Posts: n/a
Engine running rough

Have a 93 I believe 12.5 HP B/S engine that is running very rough and putting out black smoke. Worked perfect previously until the last time I started it. Had a black smoke coming out of the exhaust and a "popping" sound that increased as the throttle increased. Replaced the spark plug and fuel and it seemed to work itself out. Went to use the mower again yesterday and had the same problem. Also noticed some oil leaking from underneath where I've never had a leak before. I read about where replacing the carburetor diaphragm worked for someone. Do you think that is worth a shot here? Or is it something such as valves or rings? I think the oil leak is unrelated, and can troubleshoot that a little better than the rough engine. Thanks.

Perry
 
Sponsored Links
  #2  
Old 09-06-02, 05:23 PM
PCS
Visiting Guest
Posts: n/a
Think I figured it out and feel a little dumb for posting before looking. Took a look at the carburetor and noticed the choke was stuck open. The spring to close it was full of dirt and oil and was not closing completely. Cleaned it up and it's running smooth. I'll take a look at where the oil is coming from tomorrow...
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes