Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

2 Cycle Engine Problem


xiii13's Avatar
Visiting Guest

Posts: n/a

10-02-02, 10:16 AM   #1  
xiii13
Lawn-Boy 4.5 hp 2 stroke

I've got a lawn boy lawnmower 4.5 hp 2 stroke that runs like its at idle even though it is set at full throttle. It runs fine (no missing), starts right up, but I can't get the rpm's up to where they are supposed to be. Throttle & choke work fine, brand new spark plug, seems to be getting plenty of fuel, good spark. Any clues on where to start looking?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,566
GA

10-02-02, 09:04 PM   #2  
Hello xiii13!

Check the governor vane at the top of the carb, under the gas tank. I bet it is stuck or hung. Otherwise, it could be running too rich, or the exhaust is restricted.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
xiii13's Avatar
Visiting Guest

Posts: n/a

10-03-02, 06:16 AM   #3  
xiii13
Solved

Thanks cheese for your quick response. I had the whole thing apart last night and found the problem. The idle mixture screw had some how loosened and was almost completely out. I guess it could of been from vibrations. Runs fine now. Will have to keep an eye out on the screw to see if it stays were its supposed to.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,566
GA

10-04-02, 12:19 AM   #4  
Glad you got it going! I guess it WAS running too rich then, lol!


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread