Honda generator

Reply

  #1  
Old 02-16-03, 06:04 AM
Ken5156
Visiting Guest
Posts: n/a
Honda generator

I have a Honda ez2500 generator when I pull the starter cord I get a pull back and It rip's out of my hand. I took the plug out and it turns fine. I put some gas in the plug hole but it wont start.I have a nice spark.
 
Sponsored Links
  #2  
Old 02-16-03, 07:31 AM
mower17's Avatar
Member
Join Date: Feb 2003
Location: southern louisiana
Posts: 365
Congradulations!!!!!! You have the very well known semptoms of the classic sheared flywheel key. It only costs $1.00 so it isn't much of a project. Hope this helps.
 
  #3  
Old 02-16-03, 08:47 AM
Ken5156
Visiting Guest
Posts: n/a
I took it apart and the flywheel key is ok.
 
  #4  
Old 02-16-03, 11:45 AM
mower17's Avatar
Member
Join Date: Feb 2003
Location: southern louisiana
Posts: 365
Are you sure the key isn't slightly sheared? Is it a perfect rectangle?
 
  #5  
Old 02-16-03, 12:18 PM
rogerh's Avatar
Member
Join Date: Nov 2002
Location: Quincy
Posts: 233
It sounds like the gen. stator may have of come loose from the crankshaft. The stator acts like a flywheel and if it is loose it will kick back.
Normally there is a long bolt that runs through the stator and into the crankshaft. Check that bolt the be sure it is tight.
 
  #6  
Old 02-17-03, 11:49 AM
Ken5156
Visiting Guest
Posts: n/a
The flyweel key is ok and the stator is tight
 
  #7  
Old 02-17-03, 12:07 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Wow...I figured that one of the two possibilities mentioned would surely be the problem. Pull the plug out and see it the engine turns freely then. It might be filled with gas. If it turns freely, but no gas comes out, the next order of diagnosis would be to pull the valve cover and make sure your valves aren't stuck closed....maybe a rocker arm came off or a push rod bent keeping the valves closed.

When you turn the engine with the plug out, make sure your plug wire is not in a spot where it could spark in case gas does come out.
 
  #8  
Old 02-17-03, 05:23 PM
Ken5156
Visiting Guest
Posts: n/a
I adjusted a rocker arm and It started fine on the first pull. Runs great! Now how do I properly adjust them. I just loosened the one arm a nudge and everything worked fine. But IM a little uneasy about that. Any info on that subject would help.
Thanks
Ken
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:57 PM.