2 cycle problem

Reply

  #1  
Old 06-17-03, 06:29 AM
mrblue's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: weatherford tx
Posts: 153
home-lite weedeater

Hello,
Have a 17cc home-lite that just doesnt seem to be giving its all.
Still cuts and idles fine but seems that maybe under a load it kinda bogs down. Just replaced the fuel lines, and the plug looks to be ok, and has fresh gas. I have messed with the screws on the carb. the idle screw works fine, but the other screw doesnt seem to make that big of difference. Is there any thing to replace in the little carb that would make a difference.
thanks for the help
 
Sponsored Links
  #2  
Old 06-17-03, 01:38 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Hello MrBlue!

I believe if you'll pull the muffler off and clean it out completely, you will solve the problem. (That is what it sounds like to me anyway, and it's a common problem). Start there, and let us know how it goes!
 
  #3  
Old 06-18-03, 04:21 AM
mrblue's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: weatherford tx
Posts: 153
Thanks Cheese,
Will do that today.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:21 PM.