8hp Tecumseh carb ?

Reply

  #41  
Old 12-06-08, 03:40 PM
Member
Join Date: Nov 2008
Posts: 2
John Deere 832 Snowblower with Tecumseh 8HP engine.

I have a John Deere 832 Snowblower w/ a Tecumseh 8 H.P. Snow King engine. It is Model #H80. It has a Walbro carburetor. According to my Chilton repair manual, the carb is #631635. I disassembled the carb and soaked it in "Gunk" carb cleaner. After reassembly and installation of the carb, the snowblower started and ran fine...accept for one big problem -- gas would pour out of the atmospheric vent. My manual says that if the gasket for the fuel bowl does not seal properly, it will interfere with the atmospheric pressure. I used a new gasket and the bowl did not leak. I used compressed air after soaking the carb in the cleaner which soaked for one hour. I'm wondering if I blew out some kind of plug. Does anyone have any thoughts on this? Any help would be greatly appreciated. Thanks -- Hoot
 
Sponsored Links
  #42  
Old 12-06-08, 11:48 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
The needle and seat need to be replaced. It is leaking, causing the bowl to overfill.
 
  #43  
Old 12-08-08, 09:44 AM
Member
Join Date: Nov 2008
Posts: 2
Post 8 H.P. Tecumseh

Thanks for the information. I had wondered if that was possibly the problem, but it's great to have another opinion on this. I really appreciate the help...Have a great holiday!!
-- Hoot
 
  #44  
Old 12-09-08, 11:20 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
You too! (merry Christmas)

Let us know if you run into trouble with the repair.
 
  #45  
Old 12-20-08, 05:50 PM
Member
Join Date: Dec 2008
Posts: 1
[QUOTE=cheese;1477552]The needle and seat need to be replaced. It is leaking, causing the bowl to overfill.[/QUO
Hi all sorry if I am hi jacking the thread I am new to the forum and I am still not sure where to post my quesions but I have a similar problem with the bowl over filling and I noticed that the niddle and seat are missing which of course is why it over filling but I have also notice that when I push the primer button with the bowl full I get a spray of gas coming from a small hole in the housing of the carb right below the inlet for the prime hose.

the question is this suppose to have a hole there or nut or do I have aq bad housing
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes