Powerwasher Problem

Reply

  #1  
Old 04-14-04, 11:49 AM
Visiting Guest
Posts: n/a
Unhappy Power Washer Weak at Times

Hi All,

I have a two year old power washer (Sears). It doesn't give me all it's got (max PSI) unless I hold the spray trigger on, throttle down the motor power until the spray power kicks in and then throttle the motor power back up (never letting off the spray trigger). Almost every time I stop spraying and then press the trigger, I have to go through this ritual...not fun! Power washing sure it though when it works correctly.

Any ideas? ... I'd appreciate your input!

Thank in advance --

Kind regards - Fred
 
Sponsored Links
  #2  
Old 04-18-04, 11:37 PM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 9,721
Power Washer Weak at Times
Hi All,

I have a two year old power washer (Sears). It doesn't give me all it's got (max PSI) unless I hold the spray trigger on, throttle down the motor power until the spray power kicks in and then throttle the motor power back up (never letting off the spray trigger). Almost every time I stop spraying and then press the trigger, I have to go through this ritual...not fun! Power washing sure it though when it works correctly.

Any ideas? ... I'd appreciate your input!

Thank in advance --

Kind regards - Fred

>>>Forum Monitors Note<<<
Originally posted question was not visable to all members.
Question found and reposted here within this reply so question can be visable and thread remain intact.
==========

Fred:

Your problem could be caused by an unloader valve that is defective or out of adjustment.

If you have the manual it should show you where it is and you can check to see if it's adjustable.

Also, it is possible for a bit of dirt to get stuck in the spray nozzle which can cause the pressure to run a bit too high, causing the unloader to trip
 

Last edited by Sharp Advice; 04-19-04 at 06:32 AM.
  #3  
Old 06-02-04, 10:04 AM
yzrider
Visiting Guest
Posts: n/a
sears pressure sprayer problems

I have the same problem with mine, except now when i put the choke on is the only way to get it to go to high pressure, once it clears, or stops loading down the engine the high pressure kicks off.

I was wondering what you found to be the problem??
 
  #4  
Old 06-02-04, 10:55 AM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 9,721
yzrider,

First thing to check would be the nozzle for something stuck in it.
It doesn't have to be completely blocked for it to do what you describe.

Remove the nozzle and dismantle if an adustable one and use something like a pin to clear the tip.
Rinse it out so that the bit of what might be blocking it doesn't wind up at the tip.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes