Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Pressure washer - lacks pressure!


cooderbrown's Avatar
Member

Join Date: May 2004
Posts: 41

06-20-04, 07:58 AM   #1  
Pressure washer - lacks pressure!

I have an excell pressure washer - but the manual is lost somewhere in the house.

Anyway - there is no pressure when it runs. The model is probably 6-7 years old and I use it once to twice a year.

I tried replacing the gun, but to no avail. Water flows up to the gun - so there is no clog.

Just no pressure, like an empty water gun. Engine runs fine.

Any ideas?

Cb

 
Sponsored Links
fewalt's Avatar
Member

Join Date: Feb 2001
Posts: 3,100
VA

06-20-04, 11:56 AM   #2  
Sounds like the pump needs repaired or replaced.

fred

 
Azis's Avatar
Visiting Guest

Posts: n/a

06-20-04, 12:00 PM   #3  
Azis
Are you getting water through the gun? You said up to the gun? More info on your model IE: PSI... model # would be of more help. Here is a link for trouble shooting .pdf tips on Excell model pressure washers.

http://www.pressureparts.com/pdfs/Da...ep_trouble.PDF

 
cooderbrown's Avatar
Member

Join Date: May 2004
Posts: 41

06-20-04, 07:46 PM   #4  
It was the tip of the gun - I guess it was corroded shut...
I figured it out just by tracing the flow (rather it figured me out!)...
Still wasted most of the morning and 2 trips to Lowes.

Anyway - thanks guys!

 
Search this Thread