Pressure washer - lacks pressure!

Reply

  #1  
Old 06-20-04, 07:58 AM
Member
Thread Starter
Join Date: May 2004
Posts: 41
Pressure washer - lacks pressure!

I have an excell pressure washer - but the manual is lost somewhere in the house.

Anyway - there is no pressure when it runs. The model is probably 6-7 years old and I use it once to twice a year.

I tried replacing the gun, but to no avail. Water flows up to the gun - so there is no clog.

Just no pressure, like an empty water gun. Engine runs fine.

Any ideas?

Cb
 
Sponsored Links
  #2  
Old 06-20-04, 11:56 AM
fewalt's Avatar
Member
Join Date: Feb 2001
Location: sw VA
Posts: 3,100
Sounds like the pump needs repaired or replaced.

fred
 
  #3  
Old 06-20-04, 12:00 PM
Azis
Visiting Guest
Posts: n/a
Are you getting water through the gun? You said up to the gun? More info on your model IE: PSI... model # would be of more help. Here is a link for trouble shooting .pdf tips on Excell model pressure washers.

http://www.pressureparts.com/pdfs/Da...ep_trouble.PDF
 
  #4  
Old 06-20-04, 07:46 PM
Member
Thread Starter
Join Date: May 2004
Posts: 41
It was the tip of the gun - I guess it was corroded shut...
I figured it out just by tracing the flow (rather it figured me out!)...
Still wasted most of the morning and 2 trips to Lowes.

Anyway - thanks guys!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes