Pressuse washer troubles

Reply

  #1  
Old 08-24-04, 03:43 PM
Member
Thread Starter
Join Date: Jul 2003
Location: Montevallo, Alabama
Posts: 590
Pressuse washer troubles

I just bought a XR2600 pressure washer with an OHV 5.0HP Honda engine. After using it for approximately 45 minutes the engine cut off...it did not sound like it was running out of fuel but just abruptly stopped. I tried to restart it but the engine seemed froze up. I checked the oil level and some thin-looking oil ran out and I believe there was gas in the oil. I am going to take it back tomorrow but just wanted to get some of your opinions on what could have happened.
 
Sponsored Links
  #2  
Old 08-24-04, 07:14 PM
sceptre
Visiting Guest
Posts: n/a
Well, it sounds like you are entitled to a new unit or a refund, if you get any static.
 
  #3  
Old 08-25-04, 01:35 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
Was it full of oil/gas? If it smelled like gas, then you had a carb problem.
 
  #4  
Old 08-25-04, 06:21 AM
Member
Thread Starter
Join Date: Jul 2003
Location: Montevallo, Alabama
Posts: 590
Pressure washer problems

As per the instruction booklet, the pump is maintenance free and requires no oil. Just wanted your opinions...am going to return it...don't want to void the warranty.
 
  #5  
Old 08-25-04, 10:13 AM
Azis
Visiting Guest
Posts: n/a
I think Cheese was inquiring about the engine not the pump. If it has an adjustable pressure regulator, make sure it is backed off, I had one with such do exactly as you describe and it was also brand new.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes