Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

B&S 5HP Runs then Quits


robe559's Avatar
Visiting Guest

Posts: n/a

10-09-04, 07:40 AM   #1  
robe559
B&S 5HP Runs then Quits

B&S 5HP MTD tiller engine won't start with choke...starts after tipping the tiller forward (get fuel into system?) then runs fine for 30 sec...governor starts pulsing and engine shuts down at 45 sec. This works repeatedly. Ideas?

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

10-09-04, 10:03 PM   #2  
Sounds to me like the fuel pump diaphragm on the side of the carb needs replacing, or the pickup tube is clogged.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
propliner1's Avatar
Visiting Guest

Posts: n/a

10-16-04, 07:46 PM   #3  
propliner1
Tried turning the mixture screw in or out right after it fires? Also, look for a good tight connection and gasket at the carb manifold where it goes into the head.

-Brend.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

10-17-04, 08:45 PM   #4  
This excellent description of the problem: "starts after tipping the tiller forward (get fuel into system?) then runs fine for 30 sec...governor starts pulsing and engine shuts down at 45 sec. This works repeatedly." tells us that the fuel bowl in the tank under the carb is filling when the engine is tipped, and running dry when the engine runs for 30 seconds or so. The reason for this would be a bad pump diaphragm or clogged/missing fuel pickup. I wouldn't change the mixture screw setting since you said it was running fine during those 30 seconds.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
robe559's Avatar
Visiting Guest

Posts: n/a

10-20-04, 03:07 PM   #5  
robe559
Thanx, as soon as I can find the parts, I'll clean the carb and replace the diaphram.

 
Search this Thread