Kawasaki Fuel Pump

Reply

  #1  
Old 10-13-04, 11:27 AM
chuckx
Visiting Guest
Posts: n/a
Kawasaki Fuel Pump

I have a 17 HP Kawasaki in John Deere LX 172 and am having problems with fuel flow to the carborator. Initially I had a problem with a some crude in the gas tank. Cleaned that up but still am still getting inconsistent operation from the fuel pump. Bad fuel pump, dirty fuel pump or what?
 
Sponsored Links
  #2  
Old 10-13-04, 11:23 PM
Azis
Visiting Guest
Posts: n/a
What type of inconsistency are you getting?
 
  #3  
Old 10-14-04, 08:48 AM
chuckx
Visiting Guest
Posts: n/a
The inconsistency that I am having is: either it will not start or it will start and run for a short period of time and quit.
 
  #4  
Old 10-14-04, 09:33 AM
Azis
Visiting Guest
Posts: n/a
Ok that sounds more like a carb or fuel flow issue than a fuel pump issue. Disconnect the spark plug lead then the fuel line at the carb. Hold into a container and crank the engine. Fuel should pump in surges. If you get good fuel flow here, your problem is most likely in your carburetor and will need serviced or maybe just a good cleaning.
You might check the fuel solenoid on the bottom of the carb too. Either use a jumper lead and connect 12v to the terminal, or remove the solenoid and replace with a like threaded bolt. If this solves the problem, replace the solenoid or leave the bolt
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes