HS50 carb

Reply

  #1  
Old 11-21-04, 07:53 PM
First Pull
Visiting Guest
Posts: n/a
HS50 carb

I rebuilt the carb on a Tec HS50 as part of a tune-up and now
when it sits for a while the carb gets wet from fuel, seems to be
seeping out of the primer port, I removed the fuel bowl to see if
the float is stuck to solve the wet carb problem but it is not. Also,
when it runs it surges and setting a low idle stalls the engine,
runs rich when running when idle screw is more than 1/2 turn
out or more, seems I cannot find the setting. I disconnected the
governor but it did not help. Seems to be an adjustment carb
problem but short of pulling the carb and dismantling it again I
am temporarily at a loss. Any help is appreciated.

Update- I removed the fuel bowl & checked the float, not sticking & set at right height, blew out the main nozzle & reassembled, ran ok low & high but is hard to start when hot, Chock must be on to start.

John
 
Sponsored Links
  #2  
Old 11-21-04, 11:50 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
Hello John!

The wet area on the carb is caused by a seeping needle and seat. Did you replace them during the rebuild? Did you make certain the area where the seat goes was completely clean before installing the new seat?
 
  #3  
Old 12-30-04, 06:35 AM
First Pull
Visiting Guest
Posts: n/a
HS50 carb problem solved

It turned out to be the seat (after replacing it 3 times).

John
 
  #4  
Old 01-01-05, 12:49 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
Glad you got it!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes