Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

HS50 carb


First Pull's Avatar
Visiting Guest

Posts: n/a

11-21-04, 07:53 PM   #1  
First Pull
HS50 carb

I rebuilt the carb on a Tec HS50 as part of a tune-up and now
when it sits for a while the carb gets wet from fuel, seems to be
seeping out of the primer port, I removed the fuel bowl to see if
the float is stuck to solve the wet carb problem but it is not. Also,
when it runs it surges and setting a low idle stalls the engine,
runs rich when running when idle screw is more than 1/2 turn
out or more, seems I cannot find the setting. I disconnected the
governor but it did not help. Seems to be an adjustment carb
problem but short of pulling the carb and dismantling it again I
am temporarily at a loss. Any help is appreciated.

Update- I removed the fuel bowl & checked the float, not sticking & set at right height, blew out the main nozzle & reassembled, ran ok low & high but is hard to start when hot, Chock must be on to start.

John

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

11-21-04, 11:50 PM   #2  
Hello John!

The wet area on the carb is caused by a seeping needle and seat. Did you replace them during the rebuild? Did you make certain the area where the seat goes was completely clean before installing the new seat?


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
First Pull's Avatar
Visiting Guest

Posts: n/a

12-30-04, 06:35 AM   #3  
First Pull
HS50 carb problem solved

It turned out to be the seat (after replacing it 3 times).

John

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

01-01-05, 12:49 AM   #4  
Glad you got it!


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread