Weedeater Brand Leaf Blower

Reply

  #1  
Old 11-30-04, 06:25 PM
stlstrtrcer
Visiting Guest
Posts: n/a
Question Weedeater Brand Leaf Blower

Got a Featherlite Weedeater Leaf Blower and it's hard to start but you can eventually get it going after maybe about 10 pulls. Runs for maybe 25-30 secs. then quits. I cleaned the carb and still nothing. Also, smelled the gas to make sure it was good, smelled fine. Is it a Carb/Fuel problem? Or spark? I checked the spark plug was pretty bad, but I didn't feel like going up to Sears to get a new one, but I have an identical one in a weed whacker same #'s. It worked in weed whacker perfect. Any help thanks.
 
Sponsored Links
  #2  
Old 12-01-04, 12:32 PM
Azis
Visiting Guest
Posts: n/a
Change the Gas if in ?
If you can tell bad gas by smelling it I am sure NASA has a position open you could fill.
Check the fuel lines and filter make sure you are getting proper flow to and from the carb. (IE: from tank to carb to primer to tank)
Check the fuel tank cap vent, try to loosen the cap and see if the problem goes away.
Check the spark arrestor in the muffler (if equiped) a screen that will plug with carbon and deposits. If it is plugged it will show symptoms as you describe.
Finally if none of that helps, you may need to replace the diaphram in the carb.

If it starts and runs at all, 9 outa 10 its fuel related.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes