Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

TECUMSEH Engine Problem


cudafish's Avatar
Visiting Guest

Posts: n/a

01-23-05, 01:11 PM   #1  
cudafish
TECUMSEH Engine Problem

I have a Murry Snow blower with a 4 horse TECUMSEH. The engine would not start found the carburetor was cunked up so I cleaned it out and now the motor starts fine idle and top end. My problem is while running the motor will pop out the exhust then die. The engine will die down and sound like it lost compression I think the valves are staying open I just don't no why. When I try to pull start the first few pulls are easy like the engine is free wheeling than all of of sudden I have compression and the engine starts and runs fine until the exhust pop happens again and the engine dies again. any help would be great

 
Sponsored Links
mla2ofus's Avatar
Member

Join Date: Jan 2005
Posts: 478
TX

01-29-05, 07:02 AM   #2  
wild shot

It sounds like the exhaust valve is sticking open once it gets to max heat. If you have or can borrow a compression tester, have it and spark plug socket handy when this happens. Immediately remove spark plug and check compression. Don't know if this engine has auto. compression release. If so, could be a problem there.
Mike A

 
supertech's Avatar
Member

Join Date: Jan 2005
Posts: 189

01-30-05, 09:52 PM   #3  
backfires through carb

starving for fuel--open the high speed jet (while running)until it quits. If it does not quit, open the idle jet 1/2 turn.
Not solved clean float bowl and blow out carb with compressed air. Make sure very small hole in high speed jet is clear.

 
Search this Thread