Snowblower drive problems

Reply

  #1  
Old 03-02-05, 10:03 AM
TomD
Visiting Guest
Posts: n/a
Question Snowblower drive problems

Hi, Have a Murray snowthrower mdl. G2914000.
When the drive handle is activated the machine moves OK in all positions.
When the drive handle is released the machine does not stop foward motion for several long seconds. The owners manual does not cover the Drive clutch/auger adjustments in enough detail.
Help, thanks
Tom


 
Sponsored Links
  #2  
Old 03-02-05, 11:21 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
This will likely be one of two possible problems. Either the return spring has broken or the clutch cable has been over adjusted. If you have not adjusted the cable then it is safe to assume that the spring has broken. This spring is located in the drive train area. If you remove the inspection pan (4 screws) you will likely see a portion of the spring laying on the pan once removed. It will be verty difficult for me to explain exactly where the two mount points are but...on the left side fairly deep into the drive train area. Have someone actuate the clutch lever while you are watching the movement and perhaps this will give you insight as to where it goes. By the way, the spring part number is 313919 (old) 53818 (new). This spring is only about 1 5/8" long. Good luck and let us know how you make out.
 
  #3  
Old 03-07-05, 12:15 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Any luck yet in determining where your trouble is?
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:58 AM.