Toro Rear Bagger 21 stalling - primer problem?

Reply

  #1  
Old 05-07-05, 03:30 PM
uogecko
Visiting Guest
Posts: n/a
Toro Rear Bagger 21 stalling - primer problem?

Hi there - I'm trying to fix my own problem - I bought a used mower last summer and it hasn't given me any trouble until now. I fired it up today and although it started fine, it stalls out after a few minutes. I restart it, and it stalls sooner - then sooner, then sooner, until finally it won't start.

Plenty of oil - plenty of gas - I did notice that when I pump the primer it feels and sounds like it's bringing a lot of air in with the gas. Usually when I pump the primer I expect to feel a lot of liquid (gas) moving through however it definitely feels like there's a lot of air getting in there.

I checked for obstructions between the gas tank and tube - found nothing.

Does the fuel filter sit below the primer? It looks like the fuel line runs into a cylinder (which I'm assuming is the fuel filter) and then the primer squirts fuel up into a chamber.

I also checked the spark plug - it's not dirty and seems to spark fine.

Any ideas?

Thanks!

G
 
Sponsored Links
  #2  
Old 05-08-05, 10:46 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
Hello uogecko!

What brand, hp, and model# is the engine?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes