Primer bulb doesn't hold gas

Reply

  #1  
Old 05-28-05, 09:47 PM
Retired134
Visiting Guest
Posts: n/a
Primer bulb doesn't hold gas

undefined I have a Craftsman gas weedwacker model # 358.798550. When I try to prime the trimmer, the gas does not stay in the bulb anymore and the engine will not start. I don't know that much about gas engines but I'm trying to repair this on my own. Any help would be greatly appreciated.
 
Sponsored Links
  #2  
Old 05-28-05, 10:44 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Are you saying the fuel leaks out of the bulb? Like a hole in the bulb? Does it pump gas into the bulb at all?
 
  #3  
Old 05-28-05, 11:56 PM
Retired134
Visiting Guest
Posts: n/a
Primer bulb probelm

As far as I can tell, there isn't a hole in the bulb. There isn't any gas leaking out. I can only get a very small amount of gas into the bulb. After getting this small amount into the bulb, some gas stays in and some gas leaves the bulb. The gas does not leak out of the bulb or the base of the bulb.
 
  #4  
Old 05-29-05, 09:46 AM
repair_guy's Avatar
New Member
Join Date: Apr 2004
Location: Marion,Al.
Posts: 539
Your gona have eighter a hole in one of the fuel lines or the lines are crossed (in the wrong place on the carburetor).The bulb itself might even have a hole in it.Something is sucking air,that's not supposed to.
 
  #5  
Old 05-30-05, 10:33 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
Keep in mind that the bulb may not fill completely with gas anyway. When you push the bulb, does it return to the original position immediately?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes