Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Ryobi model 725R ?


corporal's Avatar
Visiting Guest

Posts: n/a

06-03-05, 08:32 AM   #1  
corporal
Ryobi model 725R ?

When I start it, it has no problem starting. After a brief warm-up period, I give it some throttle and it only revs up so high and sounds boggy. Only 1 plug, but if it was 2 plugs, it snds like it would be running on 1 cylinder. Just just how it snds. I took out air cleaner and washed in warm detergent water and rinsed very good and let completely dry. Sprayed entire area around carb and fuel tank to clean of grime. I choke in the open position and sprayed carb cleaner into the carb. took out fuel line splicer and snipped ends to make tighter fit. cleaned up spark plug with wire brush and regapped at 30 thousandths. Then restarted and same same. No improvement. Still snds boggy and no matter what, warmed up or cold, no difference. Even tried running with fuel cap off, no dif. Fuel flow seems to run without blockage. ?

 
Sponsored Links
mgb's Avatar
Member

Join Date: Jun 2004
Posts: 136

06-03-05, 10:16 AM   #2  
Check the spark arrestor in the muffler, it might be plugged.

 
corporal's Avatar
Visiting Guest

Posts: n/a

06-03-05, 12:32 PM   #3  
corporal
not sound simple, cuz I kinda do understand locations of things in engines, but geez. Im having a stupid attack . How do I get to the spark arrestor and what should I do when Im there? Check ? Semper-Fido !!

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

06-03-05, 02:37 PM   #4  
Two screws will remove the muff. Behind the muff and next to the exhaust gasket is the spark arrestor screen. Clean or remove it (as long as you aren't going to use the trimmer is a U.S. Forest). Also check the exhaust port for any carbon build-up.

 
Search this Thread