Huskee model 708 deck problems

Reply

  #1  
Old 06-04-05, 01:04 PM
roger c pozzi
Visiting Guest
Posts: n/a
Unhappy Huskee model 708 deck problems

My Huskee 18.5 hp tractor with a 42" deck won't cut evenly with the mulch kit installed. I've gone through all the possible adjustments 3 times and it leaves the grass high in the middle of the deck. Everything is in adjustment, the blades are new and sharp, I've tried different ground speeds, but nothing works. As of now, I make a half cut (21") to get the grass even. Sort of makes owning a tractor usless. Anybody have any ideas
The deck has only 2 blades, the deck height adjustments have been checed and double checked. I even made sure the spindles were straight and plumb.
 

Last edited by roger c pozzi; 06-05-05 at 08:49 AM. Reason: Additional information
Sponsored Links
  #2  
Old 06-04-05, 09:44 PM
Member
Join Date: May 2005
Posts: 47
deck problems

I had the same problem first make sure the center blade is spining ( I am guessing it has 3 blades ) 2nd check the height of the front and back of deck id the back is higher this will cause the center problem.


Crom
 
  #3  
Old 06-05-05, 07:04 AM
forgetful
Visiting Guest
Posts: n/a
I have a 25 hp./50 inch Huskee Supreme and purchased the leaf catching attachment that MTD sells to go with it. After installing the three mulching blades that came with the attachment, I discovered other instructions (either on a sticker on the bagging unit or in the tractor's instruction book) indicating that you should not install a mulching blade on the center spindle of the cutting deck when using the bagging sytem. Setting aside my frustation at having MTD supply parts and instructions that are inconsistent, I wonder if Roger's problem might be caused by the fact that he actually followed instructions directing him to use a different blade on the center spindle. Forgetful
 
  #4  
Old 06-06-05, 11:55 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Hello Roger!

Did you install the mulching blades as well? Are you certain that the blades are for a 42" deck instead of a 38" deck? (the same mulching kit fits both, so maybe they gave you the wrong one).
 
  #5  
Old 06-12-05, 06:47 AM
roger c pozzi
Visiting Guest
Posts: n/a
Good suggestions

I appreciate all the suggestions and am still looking for the cause of my problem. I'm staying busy though with the ideas.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 11:15 PM.