Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

RYOBI 764R Ggrass Trimmer....


wtavcar's Avatar
Visiting Guest

Posts: n/a

06-06-05, 05:47 AM   #1  
wtavcar
RYOBI 764R Ggrass Trimmer....

I have a RYOBI 764R grass trimmer for 11 years now. It has run flawlessly until now.

The problem is that is does not stay running anymore.

Have tried all of the following (in order)

- Fresh gas mixture (2 stroke)

- cleaned air filter

- replaced spark plug

- bought carb. kit and replaced all I could find. The kit is a generic Walbro kit for many models. I did not change the little mesh inside since It looked like I would have to destroy the old to put int he new so I cleaned old.
- - gaskets on both sides of the carb.
- - rubber tipped needle valve
- - little arm apparatus that moves the rubber valve

- Adjusted the idle/mixture (per the owner manual).

It starts great but idles eradic and will die instantly if I squeeze the throttle.

Have read other trimmer issues in this thread, and I would need to check muffler screen but do not think it has one

I do not see any fuel filter in the tank (because of the way it is shaped).

Any insight would be appreciated.

Thanks

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

06-06-05, 11:05 PM   #2  
Try removing the muffler and see how it does. It does sound like an exhaust restriction.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
wtavcar's Avatar
Visiting Guest

Posts: n/a

06-10-05, 06:46 AM   #3  
wtavcar
Finally got around to taking the muffler off the unit. 2 screws and all is off. Another screw then sparates the shield from the muffler. The muffler is a unit by itself. I can see the piston on the trimmer. No screen to be seen anywhere.

FYI: I live in Canada (Montreal). It could be possible that no screen comes on Canadian models.

Further investigation found the following:

There is white "cylinder" deep in the corner of the fuel tank. It appears to be a fuel filter. Have not dismantled yet. Looks messy to get it out.

I have a few questions at this point....

1) Can it be possible that the vent on the fuel cap is creating a vacuum? Can I test ?

2) While doing adjustments I tried the screw on the carb next to the idle mixture screw. I know...dummy! why did you touch it? The manual does not talk about. What is this screw and is there a "default" adjustment (Walbro Carb).

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

06-12-05, 03:00 AM   #4  
Did you try to run it with the muffler off?

The white thing in the tank is the filter but it doesn't sound like the problem here. Neither does it sound like the cap. Try backing out the high speed screw a bit (the one closest to the air filter).


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
wtavcar's Avatar
Visiting Guest

Posts: n/a

06-13-05, 10:08 AM   #5  
wtavcar
YUP!

Tried the thing with no muffler. Works fine.....BUT.... before that went one step further.

- Removed that white "filter" from the tank. Soaked it in cleaner and blew air thru it.
- Reading other links about "air", checked all the clear plastic hoses for loosness and cut off a but so that it re-seats snuggly.
- opened the carb again to change the pesky metal screen filter that I omitted on the first pass.

Put the whole thing back together and started it with no muffler. I started like a charm. So I put the muffler back on and it also started fine.

I now have inherited other problems, while getting rid of others.

1) The unit seems to run fine, but will no re-start after it is warm. I cannot get it going. Seems like vapour lock to me. The rope will not even crank.

2) Have gotten gas come out of the unit , after it is off. This may be due to putting it down after unsuccessful cranking, but am not sure.

Why the hard re-start ?

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

06-13-05, 02:21 PM   #6  
When restarting hot, crack the fuel cap slightly just bofore attempting to start. Listen for any hiss as the cap is opened. The fuel cap may not be vented properly causing a starvation, not necessarily a vapor lock. Another remotely possiblity for the hard hot restart is that the cooling fins on the cylinder are plugged with debris and overheating the unit.

 
wtavcar's Avatar
Visiting Guest

Posts: n/a

06-14-05, 12:19 PM   #7  
wtavcar
Now that you mention it I did notice the hissing noise from the cap when I open it, during the repairs. That's what prompted my vapour lock question.

There seems to be a couple of parts that makes up the cap. Will take the cap apart to see if any issues there.

Another oddity I read in the manual (which I have not followed) is that it says to "prime" the unit 5-7 times before cold starting. If I do that there is raw gas pouring from the carb. I then have to unscrew the plug, dry it, crank the unit to clear the gas, then put plug back.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

06-15-05, 12:13 AM   #8  
The carb is leaking fuel into the cylinder, causing it to hydro lock (hard starting when hot). This is also the reason gas come out when you prime and when you shut it down.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
minnpops's Avatar
Member

Join Date: Apr 2006
Posts: 1

04-02-06, 08:51 PM   #9  
keeping ryobi 764r running

WTAVCAR...mine is approx 12 yrs old & I had same problem. I found the problem, after trying nearly as much as you, that the "intake fuel line" AND the "outflow fuel line" both were very loose on the little nipple fittings due to swelling of the tubes at the connection points. This was allowing small air bubbles to accumulate until the motor died. After a short period, the fuel line would again fill, eliminating the bubbles, and start again only to repeat same problem. After putting new fuel lines on, the 764r is again running & wacking.

 
Search this Thread