Chain saw needs to be primed

Reply

  #1  
Old 07-16-05, 08:19 PM
Member
Thread Starter
Join Date: Jun 2004
Location: Missouri
Posts: 20
Chain saw needs to be primed

I have a very old Poulan inexpensive chainsaw. It has run faithfully for years. Last week I had to replace the fule line as the old one had deteriorated. I also replaced the fuel pick-up/filter in the tank.

Aftyer reassembling, I had a hard time getting it to pull fuel through the fiel line up to the carb. After priming with fuel directly into carb, it finally started and ran great. I left it for the balance of the day, and it now appears to have lost its prime again. What am I doing wrong. Did the factory pickup have a check valve, and perhaps my aftermarket replacement doesn't have one?

The Bob
 
Sponsored Links
  #2  
Old 07-16-05, 11:31 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
The carb is probably not sealing completely and allowing the fuel to drain back into the tank. Or, if the fuel line is not a tight fit on the carb, it can drain back.
 
  #3  
Old 07-17-05, 09:48 AM
Member
Thread Starter
Join Date: Jun 2004
Location: Missouri
Posts: 20
I'll pull the cover and make sure the hose is well sealed on the carb fitting. What else would be leaking inside the carb to allow the fuel to leak back?
 
  #4  
Old 07-17-05, 10:46 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
Not sure exactly what carb you have, but a leaking diaphragm (hole in it or leaking around the edge where the cover should have it sealed), or possibly an inlet neelde not seating well could cause this.
 
  #5  
Old 07-18-05, 08:28 AM
Azis
Visiting Guest
Posts: n/a
Stupid ?, is the choke plate/primer working properly?
 
  #6  
Old 07-19-05, 05:23 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Is the stupid ?, stupid me or stupid you?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes