Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Briggs & Stratton


Billybobasan's Avatar
Visiting Guest

Posts: n/a

10-14-05, 12:52 PM   #1  
Billybobasan
Briggs & Stratton

Hello Folks, I have a 12 hp B&S engine,its on a statesman riding mower. This engine has quit running 4 times,,each time its the same problem,one of the valves keeper comes of & the pring has no tension so valve quits working. I know someone else must have seen this problem & Im hoping they can tell me how to fix it. I put it(the keeper) back on & it will run for a month or all summer. I put a new one on it one time & it lasted longer than any other but still failled! HELP!!!
Bill Powell email me [email protected] or [email protected]

Forum Monitors Note:
This post has been moved (with a redirect) into this topic.
Post Also Edited:
Email Addresses only has been removed.
Contact Methods, Phone Numbers, Business Locations, Email Addresses, Personal Web Sites and or Solicitations are not allowed within the forums nor topics. Kindly Read the "Announcements" in every forum.

Sincerely, Robert Horning.
Web Site Administrator.
Sharp Advice. TCB4U2B2B Business Management Services.
Web Site Host, Forums Monitor, Moderator Hiring Agent & Multiple Topics Moderator.
Personal Reminder:
Buckle Up & Drive Safely.
"The Life You Save, May Be Your Own."


Last edited by Sharp Advice; 10-16-05 at 04:35 AM. Reason: Email Addresses In Post. Rule Violation
 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,565
GA

10-17-05, 12:20 AM   #2  
It sounds to me like the valve itself may be the problem. If the "catch" on the stem that the keeper catches on is worn, it will eventually let the keeper pop off.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread