Retired

Reply

  #1  
Old 11-15-05, 06:05 AM
Member
Thread Starter
Join Date: Nov 2005
Posts: 6
Retired

I Have A Craftsman Leaf Blower 2 Cycle.........it Ran Well For 3 Years.......this Year As I Start Using It ........it Would Start Ok...run Steady For About 5 Minutes And Then Slowly Die Off....
I Sense That Its Overheating But I'm Not Sure...when It Cools Down It Re-starts Ok And Then The Same Problem Devlopes....i Used A 40 To 1 Gas Mixture..........however I Ever I'm Wondering If There Is A Flaw In The Mixture.........what Would Too Much Oil Do??? Versus Not Enough???????? Plus Is There Any Other Suggestions Besides Oil/gas Mixture...........

Thanks.............retired
 
Sponsored Links
  #2  
Old 11-15-05, 07:40 AM
Member
Join Date: Oct 2004
Location: USA
Posts: 255
VALENTINO,

You will need to clean the air hole in the top of the gas cap.

God Bless,
Dave237
 
  #3  
Old 11-15-05, 10:55 AM
v8driver's Avatar
Member
Join Date: Sep 2005
Posts: 767
some people even run 50:1, much lower ratio of oil, too much, only thing you risk is a clogged spark arrestor. try the cap, if that doesn't do it, could be the ignition coil failing, isn't likely though.
 
  #4  
Old 11-15-05, 11:26 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Sounds to me like either the carb needs cleaning or the gas cap vent is clogged.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes