Tecumseh Snow King 8hp with electric starter

Reply

  #1  
Old 12-19-05, 08:10 PM
Member
Thread Starter
Join Date: Dec 2005
Location: Canada
Posts: 6
Tecumseh Snow King 8hp with electric starter

I have a Muarry snowblower with a Tecumseh Snow King 8hp engine with electric starter. Could not start it for this winter first snow. I plug in the power cord , press the starter switch, first it made some clicking sounds , then no sound. Could someone guide me on how to find what the problem might be, i did put in fresh gas.
 
Sponsored Links
  #2  
Old 12-20-05, 12:43 AM
Member
Join Date: Jan 2005
Location: 5353'57.39" N 12244'13.58" W
Posts: 189
sounds like the switch is toast. They are around 40 bucks canadian money way way over priced. Usually my customers replace the switch with a 3 prong plug in and just hold it in till it starts and then remove. Might try tapping the starter lightly with a hammer first while you're pushing on the button. Usually if there is no 'click' they are toast.
 
  #3  
Old 12-21-05, 06:43 AM
Member
Thread Starter
Join Date: Dec 2005
Location: Canada
Posts: 6
Thanks, I tried the the tapping the starter with a hammer while I press the switch. It made an attempt to turnover once and died.
 
  #4  
Old 12-21-05, 08:43 PM
Member
Join Date: Jan 2005
Location: 5353'57.39" N 12244'13.58" W
Posts: 189
hmmm--not a good test but a test at least. Had one last week the commutator was burnt out. Turned when I tapped it a couple times and then quit forever. Your best bet would be to bypass the switch first and see if that works. If not you're into the starter repair or replace business.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes