Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

push mower revs then sputters and finally died?


mfrancle's Avatar
Member

Join Date: Feb 2004
Posts: 81
TX

04-19-06, 02:01 PM   #1  
push mower revs then sputters and finally died?

I have a 20'' Murray Briggs & Stratton 3.5 hp push mower. I have been mowing for several weeks this year without any problem. Today, after mowing for about 20 minutes, the mower started to rev then sputter. I shut it off and put on a clean air filter. Still same problem so I put in new spark plug. Again, engine revs then sputters. I tried to finish mowing but eventually the mower just died. I tried to start it again but nothing. I waited a few minutes then tried to prime it again and still nothing. When I try to prime it, I don't feel any gas in the bulb as I prime it. What gives? Thanks.

 
Sponsored Links
mfrancle's Avatar
Member

Join Date: Feb 2004
Posts: 81
TX

04-19-06, 02:22 PM   #2  
okay, solved the problem with the gas in the primer bulb - I was out of gas. Next time, I'll check the obvious. But it still revs and sputters while it is running. Any ideas. Thanks.

 
v8driver's Avatar
Member

Join Date: Sep 2005
Posts: 767

04-19-06, 08:58 PM   #3  
I have that exact same mower.... 20 inchers are getting hard to find too... make sure the windvane governor linkage isn't binding, and the springs are still good and springy (not a real good way to tell on the springs) I'd also take the tank and carb off (comes off as a assembly anyway) go ahead and replace the diapragm/gasket (very cheap anyway) and clean the pickup tube at the bottom (theres a mesh screen down there) and just spray it out through any and all holes you see good, and rinse the tank out with a little gas.

just to be sure, is this a classic? They did make a 3.5 briggs quantum.

 
Search this Thread