Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Huskee 26hp riding mower


sami131's Avatar
Member

Join Date: Sep 2003
Posts: 23

04-28-06, 09:04 AM   #1  
Huskee 26hp riding mower

Hello,
I have a Huskee 26hp, 46" riding mower,(MTD13AZ608H131). Last night after cutting for 15 minutes, The blades stopped then the engine stopped. I found out that the fuse burnt(15 AMP). I replaced the fuse, it worked for 10 minutes then the same thing happend. Now when I replace the fuse, as soon as I turn the ignition on(before it even starts), the fuse burns. I checked all the wires to see if any is bare, they all looked o.k., no bare spots.
Any suggestions??

 
Sponsored Links
lexmarks567's Avatar
Banned. Rule And/Or Policy Violation

Join Date: May 2006
Posts: 610

05-09-06, 01:46 AM   #2  
short

you could have a short in it see if any wires are loose and hanging also is the replacement fuse the same type and rateing (i have to ask) also have the fuse box ever gotton wet spray some contact cleaner in it and try again post a picture of the problem if you can also post a wire diagram if possible so i can see if any wires are in the wrong spot if everything checks out than it might be more series have it looked at my friends car a 95 crisler cirrus had the same problem the fuse would come lose and he would have to jiggle it to get the car to start or it would blow finaly the car had enough and went up in flames while going down the road if we can't find the problem its time to get it looked at before it is to late

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

05-09-06, 02:59 AM   #3  
sami, you should stick with your original thread. http://forum.doityourself.com/showthread.php?t=262278

 
Search this Thread