Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

homelite 2 cycle primer bulb no gas


waterbug's Avatar
Member

Join Date: Jun 2006
Posts: 1

06-12-06, 07:10 AM   #1  
homelite 2 cycle primer bulb no gas

i have a new homelite blower the rope broke and i replaced the rope it started on the first pull after i went through the starting procedure. prime pull half choke run full open.the fan blade came off.now it will not start after i put the blower fan on. it is getting spark but when i pump the primer bulb no gas comes anywhere. when i take the hose off from the primer bulb there is gas there.there is compression to but it won,t even run when i put gas in the spark plug hole. thanks ted

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,570
GA

06-12-06, 10:48 PM   #2  
When the fan came off, I just imagine the flywheel key may well have sheared throwing the timing off.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Bigwind's Avatar
Member

Join Date: Nov 2004
Posts: 167

06-13-06, 01:22 AM   #3  
I'm sure a new key will solve the problem! If gas remains a problem check the fuel lines at the primer bulb. IF YOU REMOVED THEM earlier you may have reversed them while repairing?

 
mikesmalleng's Avatar
Member

Join Date: Jun 2006
Posts: 109

06-25-06, 03:10 PM   #4  
On the Homelite hand held blowers, the flywheel key and the flywheel is one unit. Most likely the key sheared but the complete flywheel will have to be replaced.

 
Search this Thread