22hp Kohler engine problem

Reply

  #1  
Old 07-19-06, 02:24 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 1
22hp Kohler engine problem

I have a Huskee mower, maybe 2000 or 2001. It has worked fine all this time and the other day it was running fine and all the sudden the RPMs shot up as if the motor was going to blow up so I shut it off. As long as you manually control the governer kinkage it will run fine otherwise it will run wide open. So I checked out the carb, all good , I also checked all the linkages everything is good and there are no signs of the linkage slipping on the governer shaft all appears well. It acts like maybe a pin or something broke. I was hoping for someone with the knowledge to fix this issue might see this. All input is appreciated. It runs fine but no throttle response and the cables are fine. HELP or off to the shop she goes.
 
Sponsored Links
  #2  
Old 07-19-06, 06:03 PM
Member
Join Date: Oct 2004
Location: USA
Posts: 255
74roostu,

Sounds like the fly weights on the govenor shaft have broken. You'll need to open up the engine to repair this however, some others here may know something specific pertaining to the Kohler govenor that I'm not aware of.

Dave237
 
  #3  
Old 07-19-06, 08:26 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
I agree that you probably have internal failure of the governor. If your linkages are intact, and the governor arm is not loose or able to slip on the governor shaft, then the governor came apart inside the engine. Don't run it this way. You'll ahve to take the engine oil pan (sump cover) off to see and repair the problem. It involves a little work, but shouldn't cost much to fix. When you get a new governor, look at all the pieces it is comprised of. Then, make sure you get all those little pieces out of the engine from the old governor before you reassemble it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes