MTD yard machine stalls under load

Reply

  #1  
Old 08-25-06, 02:18 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 2
MTD yard machine stalls under load

Hoping someone can point me in the right direction. I have a ?98 MTD yardmachine, 42 inch cut riding mower with a 14.5 HP syncho balanced OHV I/C quiet engine. Model # 287707, type 0224-01. Engine startes fine, idles and runs great. Pulls a 100 plus pound aerater up a 10% grade fine. The problem is when I engage the PTO (ie cutter blades). The engine occasionally backfires and wants to stall alot. Press in on the clutch-brake pedal and the engine well run fine, disengage the PTO and engine runs fine. Throttle control at full. THis happens in forward and reverse. The cutter blades spin free with belt off, changed the oil, fuel filter, fuel, air filter and spark plug. Cleaned around engine, removed the engine cover, fins are clear. THe question is what to do next. Is the possible problem fuel/fuel system (carb), or electrical . I am leaning towards carb. Any suggestions ???
Thanks in advance , Fixitup
 
Sponsored Links
  #2  
Old 08-25-06, 04:32 PM
Azis
Visiting Guest
Posts: n/a
Sounds like it could be a safety switch cutting out. From what you describe it does not sound like an engine issue.
I would need the model and SN of the MTD to tell more, but I would start with the seat switch.
 
  #3  
Old 08-30-06, 07:06 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 2
Talking MTD yard machine, no longer stalls under load

Thanks Az, It was the seat switch. The right side of the seat hinge was bent, causing the switch to make and break contact.
Minor adjustments and the mower continues to run under load, no backfire or stalling.

Thanks : fixitup
 
  #4  
Old 08-30-06, 07:56 PM
Azis
Visiting Guest
Posts: n/a
Glad it was a simple fix
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes