Craftsman Leaf Blower

Reply

  #1  
Old 11-05-06, 10:29 AM
Member
Thread Starter
Join Date: Jan 2006
Posts: 11
Angry Craftsman Leaf Blower

We have an older model (636.796911) leaf blower. It starts, runs for a few minutes then stalls. Spark plug was replaced, tried adjusting the idle screw but to no avail. The gas/oil mix we're using is 50:1. Any help would be greatly appreciated.
 
Sponsored Links
  #2  
Old 11-05-06, 05:29 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
Check and make sure fuel is flowing freely into carburetor. I have seen some problems with the fuel petcock on some of these older gravity feed systems. Also make sure the fuel cap is venting properly and allowing fuel to exit the tank. Finally if all else checks out, check the float needle and make sure it is not sticking closed.

It may also be a good idea to make sure you are not loosing spark when it dies.

Good Luck....
 
  #3  
Old 11-06-06, 06:51 PM
Member
Join Date: Jul 2005
Location: Texas
Posts: 205
Smile

Check to see if the fuel lines need to be replace,may have a crack in the lines,also look to see if the cylinder,has come loose,and if so it would cause a air leak,and not run.

Jerry
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes