Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

2 cycle engine problem


Doug P's Avatar
Member

Join Date: Mar 2000
Posts: 15

01-03-07, 08:50 AM   #1  
2 cycle engine problem

A Tecumseh Model OHH60 engine starts and runs fine for about one-half hour and then stalls as if it is out of gas. The engine can be restarted but only runs for a short time before stalling again. Obvious things were replaced; the spark plug and the air filter. Also, the red baffle was checked for the correct position.

 
Sponsored Links
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

01-03-07, 12:45 PM   #2  
Sounds like you have a fuel cap that is not venting properly. The cap on this vents through the cap threads and has a special gasket integral to the cap. I'll bet if you look at the cap you'll find no "guts" in there. They're likely in the tank and need to be fished out and then replace the cap with Tecumseh part number 37845. If this does not sound like it will solve your trouble then the next most likely problem area would be ignition and if not this then a possible valve issue. Check the fuel cap first and then post back. By the way, this is not a 2-cycle engine, it is a 4-stroke cycle, 6-horse, overhead valve engine.

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

01-12-07, 02:35 PM   #3  
How'd you make out Doug?

 
Doug P's Avatar
Member

Join Date: Mar 2000
Posts: 15

01-16-07, 04:36 PM   #4  
Tecumseh engine problem

Your suggestion did the trick. I purchased a new gas cap and all is well. Thank you very much for the assistance.

 
puey61's Avatar
Member

Join Date: Apr 2004
Posts: 3,224
NY

01-17-07, 12:34 PM   #5  
My pleasure and you know where to find us should you need us again. May I suggest bookmarking this site!

 
Search this Thread