Snowblower Won't Stay Running

Reply

  #1  
Old 02-13-07, 07:32 AM
Member
Thread Starter
Join Date: Feb 2007
Posts: 1
Snowblower Won't Stay Running

I have a Toro 2 cycle blower and after changing the gas, cleaning/checking the spark plug and cleaning the carb, I'm lost. If I prime the engine or put starting fluid or gas in carb it will kick over but it won't stay running. I have no idea what to do next. Is there anything else I should be looking for?

Keystone
 
Sponsored Links
  #2  
Old 02-13-07, 04:17 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
You have a fuel problem. Either the gas is not getting from the tank to the carb (fuel shutoff turned off or clogged?) or the carb needs cleaning.
 
  #3  
Old 02-16-07, 05:09 PM
Join Date: Jan 2007
Location: London
Posts: 105
See replies to "MTD snowblower...." for relevent comments re carbs.
 
  #4  
Old 02-17-07, 03:43 PM
snoman's Avatar
Member
Join Date: Dec 2003
Location: mb, can
Posts: 326
KEYSTONE
It sounds like your fuel delivery system is not working the way it should.
Depending how long it sat with gas in the system, you may be able to get away with just installing a diaphragm and gasket set. Worse case scenario it would require a complete carb kit.

snoman
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes