5hp tecumpseh needs choke on to run

Reply

  #1  
Old 03-03-07, 03:12 PM
Member
Thread Starter
Join Date: Mar 2007
Posts: 3
5hp tecumpseh needs choke on to run

i have a 5hp tecumpseh on a toro 521 snowblower. it starts fine, but will die if i turn the choke off. if i use my finger to move the throttle (bypassing the governor) i can get the engine to rev up. my initial thought was the engine is starved for fuel, but why would it rev up as described?
 
Sponsored Links
  #2  
Old 03-03-07, 06:15 PM
Azis
Visiting Guest
Posts: n/a
Unless you can rev it up with the choke off/open I would still guess you have a fuel flow issue. The restriction being in the carb.
 
  #3  
Old 03-03-07, 11:35 PM
Member
Join Date: Mar 2007
Posts: 3
You may have an adjustment valve on the bottum of the brass bowl that you can adjust to make it run. It would be in the center of the carb on the bottem not all tecumseh engines have it but it's worth a look. I would guess you need to turn it out to halp it run but if that don't work try turning it in
 
  #4  
Old 03-04-07, 12:41 PM
Member
Thread Starter
Join Date: Mar 2007
Posts: 3
problem solved

i read in some other threads about the tiny hole in the main adjustment nut underneath the bowl becoming plugged. i removed this cleaned it out with carb cleaner, a sewing needle & fishing line. i reassembled everything and had to turn the main adjustment screw out about 3 turns.
 
  #5  
Old 03-04-07, 04:20 PM
Azis
Visiting Guest
Posts: n/a
3 turns sounds a bit much. You may still have some build up on the inside of the carb where the main threads into.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes