Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Intek governor solved THANK YOU ALL!


grumpys toy's Avatar
Member

Join Date: Feb 2007
Posts: 165
NY

03-18-07, 02:24 AM   #1  
Intek governor solved THANK YOU ALL!

Good Morning,
I just wanted first to THANK all of you who helped me with this problem so THANK YOU!
I also wanted to pass on some information for others who may have this problem at some point. My engine is an B&S Intek snow #12D413 0019 E1 date code 000808FD. What I found was that it is a good idea to replace both springs at the same time!. As you all know by now my governor spring broke the long one. I replaced this but she would idle way over her limit. There are two springs on this the long one and a short one on the other side of the lever to the governor shaft. The other day I replaced the short one also and fired her up and she is now running great with no adjustments. So I guess putting on a new long spring was too much for the old short spring but when replacing this one also it put her right back.
So I guess that if your going to replace one it's a good idea to replace the other at the same time it worked for me. So Thank you all and this forum I don't know what I would do with out all your help!. Will,

 
Sponsored Links
backyardwonder's Avatar
Member

Join Date: Jan 2007
Posts: 105

03-18-07, 04:12 PM   #2  
Thanks for posting back. Always good to hear a success story. Too many guys just disappear and leave us all hanging wondering if the problem was ever solved or not.

 
Search this Thread