Mower not running right

Reply

  #1  
Old 05-06-07, 08:31 PM
Member
Thread Starter
Join Date: Feb 2002
Location: Kansas
Posts: 71
Angry Mower not running right

I have a 1998 721 Grasshopper riding mower, while mowing it sputters and looses power, I have replaced the carburetor, fuel pump and fuel filter and it has not fixed the problem. Some times it runs real good then all of a sudden it starts to sputter and looses all power and dies some times. Anyone have any idea what I should check next.
Thanks
 
Sponsored Links
  #2  
Old 05-07-07, 06:51 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Please post back with the engine make, model, spec/type, serial/code information so we know what you have for a power plant. Initially, I'd say you have an ignition related issue and most likely the ignition coil(s).
 
  #3  
Old 05-08-07, 08:17 PM
Member
Thread Starter
Join Date: Feb 2002
Location: Kansas
Posts: 71
ref information requested

It is a Kubota engine WG750-ES, WC8749 thanks
 
  #4  
Old 05-09-07, 02:17 AM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
I'm not familiar with Kubota's but you mentioned you replaced the carburetor. Isn't this a diesel engine? I didn't know Kubota manufactured a gas engine! If it is a gas, stay tuned for others who may be familiar with them.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes