LT-1650 sputtering

Reply

  #1  
Old 05-13-07, 01:19 PM
Member
Thread Starter
Join Date: Oct 2004
Location: usa
Posts: 141
LT-1650 sputtering

hello,
I bought a used LT-1650 with 95.5hrs.

It worked fine at first, but when I refilled the gas tank, it would not stay on! It would rev up and down over and over.(much like if you were pressing on a gas pedal, and letting go). sometimes would stay on a while. when I started to mow, it would be worse and eventually stall!

Since the only thing that changed was the gas, I drained the gas I had just put in. I saw a very small piece of plastic int teh gas tank, in the hole where the gas goes into the gas line.
I discarded that (I hope it's not needed) and replaced the gas with gas from another gas station.

I needed to jump it to start it, but it finally started. It is running much better (actually staying on), but it still has a tendency to rev up and down some, even when stopped!

I was actually able to finish mowing the lawn, but what is causing this?

I'm not sure if I should have it serviced! I don't own a truck, so it's kind of a pain to get it to a shop.

I would appreciate any help.
Thank you.
 
Sponsored Links
  #2  
Old 05-13-07, 06:00 PM
Azis
Visiting Guest
Posts: n/a
Try loosening the fuel cap. It could be as simple as the cap vent. Otherwise it sounds like something has gotten into the fuel system causing a restriction.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes