Craftsman B&S 6.5 Lawn Mower

Reply

  #1  
Old 06-02-07, 04:10 PM
Member
Thread Starter
Join Date: Jun 2007
Location: Neola
Posts: 1
Cool Craftsman B&S 6.5 Lawn Mower

I have a Craftsman 6.5 horse Lawn mower, with a B&S motor. I bought it new and its about 3 years old. It mowed great last year with no problems. This year, It runs for about 2-4 minutes before acting like it is flooded. I noticed it was flooding the air filter and gas was coming out the primer bulb. I tore into the carb to see if anything was stuck in it, but couldn't see anything. The float seems to be working fine. I changed the air filter after it was flooded. I don't think the spring on the carb is stretched. It is just getting very annoying trying to mow the lawn, only getting a little done at a time before I have to wait for the "flooding" to subside. If anyone has any ideas on how to fix this problem, please let me know. It doesn't have any problems starting, and I just sharpened the blades, so it isn't bogging down in the grass. My husband is at a loss with it too. Please help! Thanks!
 
Sponsored Links
  #2  
Old 06-02-07, 04:32 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
You have a carburetor related issue and rather than trying to pinpoint any one issue, I recommend reconditioning the carburetor with a Briggs rebuild kit. If you post back with the model, type and code numbers, I can provide you with the part number(s) you'll likely need.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'