MTD rider dies under load

Reply

  #1  
Old 06-05-07, 06:08 PM
Member
Thread Starter
Join Date: Jun 2007
Posts: 2
MTD rider dies under load

I have a MTD rider with a 17HP INTEK Briggs and Stratton engine. Starts fine and runs great while in Neutral. As soon as it is put in gear or deck is engaged the engine dies out. Replaced plugs, air filter, fuel filter with no help. It is obviously getting spark since it runs at full throttle in neutral but could it still be a magneto issue? Please help.
 
Sponsored Links
  #2  
Old 06-05-07, 08:22 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Sounds to me like the seat switch is not operating correctly.
 
  #3  
Old 06-06-07, 12:56 PM
Member
Thread Starter
Join Date: Jun 2007
Posts: 2
mtd dies out under load

The seat switch is jumpered out.
 
  #4  
Old 06-06-07, 06:52 PM
puey61's Avatar
Member
Join Date: Apr 2004
Location: Upstate New York
Posts: 3,224
Jumpered out? You mean there is a jumper wire between the terminals of the seat switch? If so, there should not be, the jumper completes the kill circuit. How many terminals are on your seat switch? Post back with your chassis' ID numbers as well as the engine's numbers, please.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes