Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

changed flywheel key


flywheel's Avatar
Member

Join Date: Jul 2007
Posts: 1

07-01-07, 03:49 AM   #1  
changed flywheel key

l 2 week's ago i purched a used mower on e-bay taking in home i changed oil,spark plug,blade,air filter etc mower was running pefect just wanted too change all the item's that would make it a dependable mower after changing everything i heard a lound thumping noise coming from the blade like it was loose shut mower off, tight blade onto adapter as it was loose mower would no longer start and had no spark threw e-bay ordered 670306 flywheel puller and 611004 flywheel key mower is a craftsman 917-376290 6hp engine no 143-966010 flywheel key was indeed sheared replaced key tighten flywheel nut went too start mower still no start or no spark any and all help would be appreciated naturally i reied a new plug,

 
Sponsored Links
geogrubb's Avatar
Member

Join Date: Jun 2006
Posts: 2,333
MO

07-01-07, 09:57 AM   #2  
If when you replaced the key you didn't tighten the flywheel nut properly(50-55 ft lb, I think) you could have sheared the key again. Do you know what caused it to shear the first time, usually it is necessary to hit something pretty hard for those keys to shear. Rather than order parts from ebay you should be able to pick up the keys at any small engine repair shop or Sears. Have a good one. Geo

 
30yearTech's Avatar
Member

Join Date: Oct 2006
Posts: 1,176
TX

07-01-07, 08:16 PM   #3  
Chances are your loose blade caused the flywheel key to shear initially. If you never got the engine to start after replacing the key then it's probably still good. No spark would indicate either the kill switch is grounding out, or the CDI module is bad.

Remove the kill switch lead wire from the CDI and test for spark. If you have spark then trace down the lead to the kill switch tab underneath the flywheel for a grounded condition. If you still have no spark with the kill switch lead unplugged then you can try cleaning the mounting contacts between the laminations and mounting posts and check for spark again. If still no spark then I would suspect a faulty CDI module.

 
Search this Thread