Ryobi 780R

Reply

  #1  
Old 07-18-07, 03:56 PM
Member
Thread Starter
Join Date: Jul 2007
Posts: 1
Unhappy Ryobi 780R

I am having trouble with my Ryobi 780R..and hoping someone can help. It was running this year, and then just died and I have not been able to get it going again.
I have checked and replaced the spark plug..my tester shows I am getting good spark. I have replace the fuel lines. I have rebuilt the carb and the plug is wet, so it is getting gas.
Compression is good. The switch seems to be working, the plug sparks when it is on and does not spark when turned off. I have removed the muffler..it is clear and the ports are clear as well.

The machines does not even attempt to run....You pull and pull but nothing. I have even used that sure start spray from the local hardware store...but nothing..it does not attempt to start....
Does anyone have any ideas

Thanks
 
Sponsored Links
  #2  
Old 07-18-07, 06:28 PM
30yearTech's Avatar
Member
Join Date: Oct 2006
Location: Central Texas
Posts: 1,176
A sheared off timing key in the flywheel or a massive air leak could cause a problem like you describe. I would check the flywheel key first and if that checks out ok then I would look for loose mounting screws around the crankcase cover, cylinder and carburetor and finally the crankshaft seal.\

Good Luck...
 
  #3  
Old 07-18-07, 11:13 PM
Member
Join Date: Feb 2005
Location: Michigan
Posts: 335
I'll second the checking of loose mounting screws on the cylinder.
 
  #4  
Old 07-19-07, 06:29 AM
msidan's Avatar
Member
Join Date: Apr 2006
Location: Gouverneur
Posts: 289
I'll third that. Had that happen to me before.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:39 AM.