Riding Mower Electric Blade Engage - short?

Reply

  #1  
Old 07-25-07, 09:08 AM
Member
Thread Starter
Join Date: Aug 2005
Location: Georgia
Posts: 2
Riding Mower Electric Blade Engage - short?

My TroyBuilt riding mower developed a wierd glitch after a local service center worked on it. My model has the knob up near the steering wheel that you pull up to electrically engage the cutting blades. Now, for some reason when I pull it up, I also have to wiggle the ignition key slightly before the blades will engage. Can someone point me in the right direction for determining how to pinpoint the electrical problem here?
 
Sponsored Links
  #2  
Old 07-25-07, 05:06 PM
CAMINO KID's Avatar
Member
Join Date: Mar 2007
Location: Southern Wisconsin
Posts: 354
It is going to be hard but sounds like a wire is loose or corroded. Unplug the PTO switch and reinstall and do the same with the ignition switch wires. If this does not help I would take it back to the shop and complain about the repairs. Most shops offer some warranty on their work other than the tail light warrnty. Electrical troubleshooting can be a hassel if you do not have the equipment.
 
  #3  
Old 07-25-07, 10:11 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,818
Got the plastic keyswitch? My bet would be a bad keyswitch that just happened to go bad (coincidence rather than the shops fault).
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes