Weedeater FL 26

Reply

  #1  
Old 07-29-07, 12:55 PM
Member
Thread Starter
Join Date: Jul 2007
Location: Finger Lakes of New York State
Posts: 4
Weedeater FL 26

New Weedeater purchased at Sears, only used twice. Hard starter right out of the box. Purchased last fall and wife discarded sales slip. Only cost 65 bucks so hate to put more money into it but feel ripped of by a nonrunning piece of new equipment. Have done everything suggested on this forum, new gas, new plug, and so on. Pulled plug after each start attempt and the plug is wet even though no choke was used. Think engine is flooding it's self but no adjustment on carburator.
Thanks for your help
 
Sponsored Links
  #2  
Old 07-29-07, 01:20 PM
Member
Join Date: Jul 2005
Location: Texas
Posts: 205
Smile

Are you sure you are getting a good spark,take the plug out and ground it to the cylinder to see if you have spark,if so try taking the muffler off and check the spark arrester,I know you said it was new,try starting it with the muffler off the muffler could be clogged.

Jerry
 
  #3  
Old 07-29-07, 02:57 PM
Member
Thread Starter
Join Date: Jul 2007
Location: Finger Lakes of New York State
Posts: 4
Weedeater FL26

Have done all that.
Thanks
 
  #4  
Old 07-29-07, 09:08 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Look for a build date on the trimmer. That might get you some warranty. Sounds like a carburetor problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes